Help With Recording and Sending Voice Messages With the Raspberry Pi B+

This is the space to ask all your burning tech questions and discuss the Skills Bright Sparks competition. We are here to help!
Post Reply
ZebH
Posts: 58
Joined: Thu May 12, 2016 4:50 pm

Help With Recording and Sending Voice Messages With the Raspberry Pi B+

Post by ZebH » Wed Jan 16, 2019 7:46 am

Hi everyone!

I am working on a project with the Raspberry Pi B+ that when you say the key word (like 'start') it starts recording sound from the USB microphone and when you say 'send' it stops the recording and save it to the SD card and transmits the file wirelessly to another Raspberry Pi (or some other device) and plays the recording through a speaker!

The first step that I am doing is to when you say 'LED On' it turns the LED on, and when you say 'LED Off' it turns the LED of. I have found a great tutorial for doing this that I will link down below shortly!

After that I will get it to record then stop recording when I say the word, and save the file to the SD card.

Then I will get it to play the file through a USB speaker on the same device that did the recording.

And finally I will transmit it wirelessly to another device which will play the sound track!


I am thinking how to transmit the sound wirelessly (I want about 100m of range), is the inbuilt Bluetooth on the Pi a good option? (If I did that I could send it strait to a Bluetooth Speaker) If it isn't do you have any ideas on what would be a good option?

Any help along the way with this project would be wonderful!

Thanks very much!
~ Zeb

ZebH
Posts: 58
Joined: Thu May 12, 2016 4:50 pm

Re: Help With Recording and Sending Voice Messages With the Raspberry Pi B+

Post by ZebH » Wed Jan 16, 2019 9:45 am

Sorry it is a 3 B+!

The link to using your voice to turn on and off an LED.
https://www.instructables.com/id/Raspbe ... utomation/
~ Zeb

HenryIdomo
Posts: 8
Joined: Sun Feb 03, 2019 6:55 am
Location: Sri Lanka
Contact:

Help With Recording and Sending Voice Messages With the Raspberry Pi B

Post by HenryIdomo » Wed Mar 13, 2019 12:36 am

I have another issue with your sweepstakes. It isnt marking the sweeps I know Ive entered as submitted. When it is a manual one I click on mark as submitted. What am I doing wrong?

Post Reply